Printing error click print button/icon in viewer in window application how solve

  • agsoftwares 2 years, 6 months ago

    when click print icon in viewer (active report v 9) then show this error but MS-Office print normally,
    how to solve this error?

    error below :-

    Exception details:
    System.ComponentModel.Win32Exception (0×80004005): The data is invalid
    at System.Drawing.Printing.PrinterSettings.GetHdevmodeInternal(String printer)
    at System.Drawing.Printing.PrinterSettings.GetHdevmodeInternal()
    at System.Drawing.Printing.PrinterSettings.GetHdevmode()
    at System.Drawing.Printing.PageSettings.get_PaperSource()
    at GrapeCity.ActiveReports.Viewer.Win.Controls.CustomPrintDialog.RunDialog(IntPtr hwndOwner)
    at System.Windows.Forms.CommonDialog.ShowDialog(IWin32Window owner)
    at System.Windows.Forms.CommonDialog.ShowDialog()
    at GrapeCity.ActiveReports.Viewer.Win.Printing.PrintImpl.#zs(#q0B documentPrintAdapter, Action`1 action)
    at GrapeCity.ActiveReports.Viewer.Win.Printing.PrintImpl.Print(#q0B documentPrintAdapter, Boolean showPrintDialog, Boolean showPrintProgressDialog, Boolean usePrintingThread, Action`1 action)
    at GrapeCity.ActiveReports.Viewer.Win.Printing.PrintImpl.Print(DocumentModel documentModel, ReportModelBase reportModel, IApplicationContext context, Boolean showPrintDialog, Boolean showPrintProgressDialog, Boolean usePrintingThread)
    at GrapeCity.ActiveReports.Viewer.Win.WindowsPrintService.Print(DocumentModel documentModel, ReportModelBase reportModel, IApplicationContext context, Boolean showPrintDialog, Boolean showPrintProgressDialog, Boolean usePrintingThread)
    at GrapeCity.Viewer.Common.ViewModel.ToolbarViewModel.<>c__DisplayClass3e.#9kz()

  • 130p
    Mohita130p 2 years, 6 months ago

    Hello,

    Please note that, if an operation fails with Eroor 0×80004005,it denotes ‘Access Denied’. Please refer to the following link:

    http://www.windowsanswers.net/slimware/fix-0×80004005

    Hence, request you to check whether your application has the required access to the required printer/location etc.

    Also, ensure that you have the local Administrator rights.

    You are also requested to :
    1. Test using the latest AR Sp1 release :

    http://www.gcactivereports.com/Download/ActiveReports/

    2. Try running the same sample on some other machine and see if you still face the same issue.
    3. Share with us the name of the printer(s) installed on your system and the default printer.
    4. Do you get the same error when printing the report via any printer than the default printer or is it specific to a printer
    5. Also, is the issue replicable when printing any specific report or when printing any report?

    Regards,
    Mohita

  • agsoftwares 2 years, 6 months ago

    system having local Administrator rights.
    using Active report V 9,

    Try running the same sample on some other machine and see if you still face the same issue.-yes,problem same,
    the same error when printing the report via any printer than the default printer or is it specific to a printer–any printer
    Also, is the issue replicable when printing any specific report or when printing any report? any report

    my problem not solve

  • 130p
    Mohita130p 2 years, 6 months ago

    Hello,

    Just to re-confirm, are you using the latest version of AR9 : 9.1.2302.0?

    Thank you for the information shared by you. You are requested to share your sample application with us and also the name of the printers with which you tested the issue.

    It would also be helpful if you could share with us the machine configuration on which you are facing this issue.

    We would then try to replicate the issue at our end and would assist you accordingly thereafter.

    Regards,
    Mohita

  • Cristian0302 3 months, 1 week ago

    Hi,

    My name is Cristian i write you from Auto Total team we encounter an error message.Its the same above here.I must specify that we use AR 10 and in our case we are logged with and administrator windows user.Please advise me how can i solve this problem.
    “Exception details:
    System.ComponentModel.Win32Exception (0×80004005): The data is invalid
    at System.Drawing.Printing.PrinterSettings.GetHdevmodeInternal(String printer)
    at System.Drawing.Printing.PrinterSettings.GetHdevmodeInternal()
    at System.Drawing.Printing.PrinterSettings.GetHdevmode()
    at System.Drawing.Printing.PageSettings.get_PaperSource()
    at GrapeCity.ActiveReports.Viewer.Win.Controls.CustomPrintDialog.RunDialog(IntPtr hwndOwner)
    at System.Windows.Forms.CommonDialog.ShowDialog(IWin32Window owner)
    at System.Windows.Forms.CommonDialog.ShowDialog()
    at GrapeCity.ActiveReports.Viewer.Win.Printing.PrintImpl.#zs(#q0B documentPrintAdapter, Action`1 action, Boolean useStandardDialog)
    at GrapeCity.ActiveReports.Viewer.Win.Printing.PrintImpl.Print(#q0B documentPrintAdapter, Boolean showPrintDialog, Boolean showPrintProgressDialog, Boolean usePrintingThread, Boolean useStandardDialog, Action`1 action)
    at GrapeCity.ActiveReports.Viewer.Win.Printing.PrintImpl.Print(DocumentModel documentModel, ReportModelBase reportModel, IApplicationContext context, Boolean showPrintDialog, Boolean showPrintProgressDialog, Boolean usePrintingThread, Boolean useStandardDialog)
    at GrapeCity.ActiveReports.Viewer.Win.Printing.PrintImpl.Print(DocumentModel documentModel, ReportModelBase reportModel, IApplicationContext context, PrintingSettings settings)
    at #1sz.#RiL.Print(DocumentModel documentModel, ReportModelBase reportModel, IApplicationContext context, PrintingSettings settings)
    at GrapeCity.Viewer.Common.ViewModel.ToolbarViewModel.<>c__DisplayClass3e.#9kz()”
    Thank you for your support.

  • 195p
    AbdiasM195p 3 months ago

    It is really difficult to comment on the cause of the error from just the stack trace. It seems it is throwing an error when trying to open the Print dialog, but it’s just a guess. To be more accurate, I would need some information from you i.e

    - Which printer are you using to print?
    - Is it a network printer?
    - What is the exact version of ActiveReports that you are using? (Is it AR10 SP3?)
    - What type of report are you facing the error with? Is it with only one report or all reports?

    Can you please try uninstalling and re-installing your printer and its drivers. If it doesn’t help, please send across your application for me to check.

    Thanks

  • Cristian0302 3 months ago

    Hi again,
    So i just talk with the client who encounter this issue,he got our app instaled on 3 desktops, but they receive this error message only at one of them.
    He got the same version of OS ( windows 10), the printer you asked for her name/model is Samsung Xpress M2070F. This error is received for all the reports.All the reports are unable to print. Also you asked about the printer and i must specify that the printer is connected to desktop with the issue and we try to re-install the driver of this printer.I try to print some files saved on desktop and it worked, i also try to connect print to another printer same series and i received the same error.
    We would like to inform you that we are using AR10 SP(i dont know it) the version of setup is ActiveReports_v10.0.5602.0.msi maybe this will be helpfull.

    If you need furher information please do not hesitate to text me back.
    Thank you for your cooperation

  • 195p
    AbdiasM195p 3 months ago

    Thanks for the information. As you mentioned, the issue occurs on only one desktop machine but works fine on others, it is a machine specific issue. The version 10.0.5602 was the first release of AR10 and I would’ve asked you to update to SP3 (10.3.9175.0) had it not worked on all machines. You can still update to SP3 since you have the AR10 license. Download link – http://cdn.grapecity.com/ActiveReports/ar10/ActiveReports-v10.3.9175.0.msi

    Can you try uninstalling and re-installing the application on the machine where error occurs. Is the account an administrator account where the application is installed? Please make sure the application and account have sufficient permissions to print.

    If the issue persists, can you send across your application so that I can also try replicating the issue at my end.

    Thanks

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.