Section Report Blank Rows

  • VK_ActiveReports 6 months, 3 weeks ago

    I am using SectionReport and SubReport to display collection(array) data. SectionReport has column count 4 (down across). SectionReport detail format event invokes SubReport and Pass the collection data. For the most part it is working. However, it is creating random blank rows (space) in the final PDF.
    Blank rows/space looks almost same height as SubReport. Not sure what is missing here. Please let me know how to correct/remove these blank rows/spaces. Attached please find the screen shot.

    Attachments:
    1. SectionReport-Blank-Rows

      SectionReport-Blank-Rows.png

  • 195p
    AbdiasM195p 6 months, 3 weeks ago

    Sorry, the behavior you’ve mentioned is not reproducible at my end. I have attached a sample application similar to your scenario which contains the Pdf output as well. Kindly check and let me know if you’re doing anything differently. If you can attach your application, it’ll be much helpful. Also, which version of ActiveReports are you using? I tried this with the latest version 11.0.8705.0.

  • VK_ActiveReports 6 months, 2 weeks ago

    Thanks for your reply. Please try with column count 3 or 4 with couple of 100 records. Pl make sure you that have couple of controls like TextBoxes in subreport. It can easily reproducible. However, this behavior is varying based on the record count. Some case it appears OK and in other cases, it is creating lot of white space or unnecessary page break. As an alternate if I use single textbox with multiple values appended with line break looks ok .

    TextBox1.Value = Field1+ “\n” + Field2 etc
    vs
    TextBox1.Value = Field1
    TextBox2.Value = Field2

    It may take some time to create a true sample application with test data.

    If I need to use single TextBox approach, then please guide me how can I achieve the attached one using RichTextBox.

    Attachments:
    1. WhiteSpaceIssue_MultiColumnSubReport

      WhiteSpaceIssue_MultiColumnSubReport.png

  • 195p
    AbdiasM195p 6 months, 2 weeks ago

    I tried with more than 2000 records but still couldn’t reproduce the issue. I have attached the modified application and the pdf file for your reference. It’ll be much helpful if you can send across your report along with the data so that I can reproduce it here and provide you with a solution.

    Thanks

  • VK_ActiveReports 6 months, 1 week ago

    Thanks for the sample code. Please try using KeepTogether true both in Main and Sub Report. ActiveReport engine leaving lot of white space even though the next record can fit it into that space. This behavior varying based on the data.

    Roughly 4 years back I opened an issue similar to this. Here is the link for your reference.

    http://arhelp.grapecity.com/groups/topic/subreports-missing-data-in-first-row-first-column-from-second-page-onwards/

    It is OK to have blank space only when the next record cannot fit it into the remaining column space. However, AR is not working that way. Please let me know how can we fix this issue without leaving blank spaces with KeepTogether. Let me know if there is any workaround. Scenario is to show Customers information in State, County and City sort order. If there are multiple Customers in singly City, then City should not repeat. All the Customers belong to that City should show under that City heading. Same applies to City. There could be multiple Cities in County and County should be displayed only once and it should display all the Cities under that.

    State1

    County 1

    City 1
    Customer 1 Information
    Customer 2 Information

    City 2
    Customer 1 Information
    Customer 2 Information
    Customer 3 Information

    County 2

    City 3
    Customer 1 Information
    Customer 2 Information

    City 4
    Customer 1 Information
    Customer 2 Information
    Customer 3 Information

  • 195p
    AbdiasM195p 6 months, 1 week ago

    I tried with KeepTogether set to true and it does leave blank spaces but only when the next detail section cannot fit in that space. I’ve attached the pdf file with this setting. Please take a look and let me know if you see any place where there is empty space even though the next record could get fit in that space.
    Also, please confirm the version of ActiveReports you’re using. I’m using version 11.0.8705.0.

  • VK_ActiveReports 6 months, 1 week ago

    I could not see the attachment. Please attach the pdf to compare with local version. I am using AR10 Version 10.0.5602.0.
    This is more noticeable when you have a control in main report and few controls in sub reports. It varies based on data. Let me try the same with AR11.

  • 195p
    AbdiasM195p 6 months, 1 week ago

    Sorry, there was some issue with attaching files on forums. It has been fixed and I’ve attached the pdf file now.

    Attachments:
    1. AR.pdf
  • VK_ActiveReports 5 months, 3 weeks ago

    I still see lot of white spaces in the PDF that you attached. On many pages next record can easily fit in those white spaces. Let me know if there is any workaround to fix this or any other approach. Is there any way to control on adding those records in each page down across (filling the rows, then move to next column) and forcing page breaks from the code?

  • 195p
    AbdiasM195p 5 months, 3 weeks ago

    Can you let me know the pages in the attached Pdf where there are white spaces and the next record can easily fit in? If it is an issue, then we’ll need to get it rectified. It is not possible to control the adding of records. If the KeepTogether is set to true, then ActiveReports engine determines whether the next record can fit in or not and adds a page break accordingly.

  • VK_ActiveReports 5 months, 2 weeks ago

    I just reviewed first 10 pages Page 3, 7, 8 and 10 got scope to fit the next record in those white spaces.

    As mentioned earlier our requirement is to show Customers information by State, County and City sort order. If there are multiple Customers in singly City, then City should not repeat. All the Customers belong to that City should show under that particular City heading. Same applies to County and City . There could be multiple Cities in County and County should be displayed only once and it should display all the Cities under that. What is the best way to achieve this without having much white spaces.

    We tried the following approaches
    State, County and City under main report and Customer information under sub report
    State under main report, County, City and Customer information under sub report

    Keep together true keeps lot of white spaces, keeptogether false shows State/County/City information at the bottom of the column (for some records) and the associated Customer information showing under next column. We want to show these fields together with out leaving much white space. Some white space is OK when the next customer information does not fit in that column. Please suggest what would be the best approach to solve this. If possible could you provider us some sample code?

    State1

    County 1

    City 1
    Customer 1 Information
    Customer 2 Information

    City 2
    Customer 1 Information
    Customer 2 Information
    Customer 3 Information

    County 2

    City 3
    Customer 1 Information
    Customer 2 Information

    City 4
    Customer 1 Information
    Customer 2 Information
    Customer 3 Information

    Attachments:
    1. WhiteSpaceIssue_MultiColumnSubReport

      WhiteSpaceIssue_MultiColumnSubReport.png

  • 195p
    AbdiasM195p 5 months, 2 weeks ago

    I’m going to get in touch with our development team and inquire if there is any way of improving the layout in this scenario. I will get back to you when I have any information for you. Tracking Id – 229564

  • VK_ActiveReports 5 months, 1 week ago

    Please let me know if you got chance to talk to your development team. This is one of the critical item for us and we are getting lot of pressure from our clients on this.

  • 195p
    AbdiasM195p 5 months, 1 week ago

    The development team has replied saying it is the design behavior if the ColumnDirection of the Detail section is set to AcrossDown, then there are more blank spaces in order to fit in the largest record within a row. But if the ColumnDirection is set to DownAcross, then the blank spaces are reduced to a large extent because the records are rendered one below the other and move to the next column only when one column is entirely filled up.
    I have attached the modified sample application and the pdf where the blank spaces are very less. Please take a look. If you’re facing the issue in your application, then kindly send across a stripped down version of your application where we can replicate the issue.

  • VK_ActiveReports 5 months, 1 week ago

    Column Direction is already set to Down Across. It may take sometime for me to get the striped down version of it with some dummy data.

    Meanwhile if you could provider any suggestion/best approach/sample code to cover the scenario mentioned below, that would be great. Basically it has multi levels (i.e. multi Parent Child). In this case State, County, City, Customers.

    State1

    County 1

    City 1
    Customer 1 Information
    Customer 2 Information
    ………

    City 2
    Customer 1 Information
    Customer 2 Information
    Customer 3 Information
    ……………….

    County 2

    City 3
    Customer 1 Information
    Customer 2 Information
    ……

    City 4
    Customer 1 Information
    Customer 2 Information
    Customer 3 Information

    State2
    …………………

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.