Trial period has expired message after 15 export in pdf

  • paoloz 1 year, 1 month ago

    Hi,
    in a winservice I have an export to pdf functionality.
    After 15 runs, I have the message:

    Your Trial period has expired. | Source: GrapeCity.ActiveReports.v7 + Void Run(Boolean) | Stack: in GrapeCity.ActiveReports.SectionReport.Run(Boolean syncDocument)

    The licx file is in the project with the lines:
    GrapeCity.ActiveReports.SectionReport, GrapeCity.ActiveReports.v7, Version=7.3.7973.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff
    GrapeCity.ActiveReports.Export.Pdf.Section.PdfExport, GrapeCity.ActiveReports.Export.Pdf.v7, Version=7.3.7973.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff
    GrapeCity.ActiveReports.Design.Designer, GrapeCity.ActiveReports.Design.Win.v7, Version=7.3.7973.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff
    GrapeCity.ActiveReports.Viewer.Win.Viewer, GrapeCity.ActiveReports.Viewer.Win.v7, Version=7.3.7973.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff
    GrapeCity.ActiveReports.Web.WebViewer, GrapeCity.ActiveReports.Web.v7, Version=7.3.7973.0, Culture=neutral, PublicKeyToken=cc4967777c49a3ff

    Any idea ?

  • 597p
    Reema597p 1 year, 1 month ago

    Hello,

    Please run the LicenseManager as Admin and see if the product is correctly activated on your system. Also, share the screenshot of the same with us.

    Next, do ensure that the required dll(s) are present in the References folder of the project. Please refer to the following documentation link for further clarity :

    http://helpcentral.componentone.com/nethelp/AR7Help/OnlineEn/arHOWLicensingActiveReports.html

    If the issues still persist, then kindly share the following information :
    - create a simple application with PDF Export and see if the issue is replicable ?
    - share a stripped down sample application(could be a dummy project) that replicates your issue
    - is the issue observed on development machine or deployment machine ?
    - environmental details on which the issue is replicable

    these would help me to assist you appropriately.

    Regards,
    Reema

  • paoloz 1 year, 1 month ago

    Hello,
    the development machine where I’m having this issue is regularly licensed and, in a winforms application, I have no problem with pdf export or with red info line at the page bottom.
    The only difference is that the pdf export is maded by a win service on the same machine with the same licx and referend dll of the winforms application.
    Regards, Paolo.

    Attachments:
    1. Capture

      Capture.jpg

  • 597p
    Reema597p 1 year ago

    Hello Paolo,

    I tried to replicate your scenario in a test application with AR7 : running the PDF Export over 15 times but was unable to reproduce the issue on my Windows7 or Windows8.1 machines. Attached is my sample for your reference.

    I request you to please :

    - make the necessary changes to my sample app such that I could reproduce your issue at my end
    - share your Environmental details wherein the issue is reproducible.
    - create a simple application with PDF Export (on a button click and not via Windows service) and see if the issue is replicable ?

    Regards,
    Reema

    Attachments:
    1. WinApp.zip
Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.